RetroChallenge 2021/10 Entry: PowerMac G4 repair

Hi Everyone,
My entry for RetroChallenge 2021/10 is this PowerMac G4 that powers on, but no video.

I have already taken it apart this morning. Found some leaky capacitors. Photos to follow.

Google Photos

3 Likes

That’s great - would love to hear how you get on.

Worked out capacitors that went bad.
C193 22uF 35v
C940 330uF 16v
C937 100uF 6v
C3568 220uF 35v
C3570 220uF 35v
C3308 100uF 6v
C3307 100uF 6v
Google Photos
Google Photos
Google Photos
Google Photos

2 Likes

Bad looking caps swapped out. Reassembled everything. No change. Still chimes, and still no video. Next I will check voltages on the power supply (should have looked at that first).

4 Likes

Here’s the details of the WOzFests I’m holding - feel free to join via Google Meet.

And I might even be able to have 10 attendees at WOzFest 22!

hey Jon,
I’ve done similar repairs to a Mac Classic II. Those aluminium caps are the pits. Like you I had a lot of corroding stuff near to the caps that leaked. Luckily for me my Mac was still working when I last did this about 20 years ago. I think I lost sound on one of the Classic Macs I did and that was due to tracks being eaten by corrosion.
I was thinking of using SMD tantalum caps next time I do one of these repairs as they don’t die and eat the PCB tracks, although they might explode instead :slight_smile: However the Apple //e uses axial tantalums and I’ve only ever had one of those fail in 37 years so it’s not such a stupid idea.
good luck,
Mark C

1 Like

Spent the last few hours checking power lines. Here’s what I found: Power supply voltage lines are OK. Then I noticed that the mouse doesn’t “light up” (plugged into keyboard acting as hub).

On a known-good machine, the mouse lights up immediately after powering on. I suspected a fault in the USB 5v line (or some other voltages).

Took logic board out again. A previously repaired capacitor has fallen off. I have re-soldered this one. And nothing else stands out. Upon reassembly, plugged mouse directly into USB port, and it lights up on boot. Apparently it isn’t initialising the hub and/or keyboard as the mouse does not light up when plugged via the keyboard. So there is USB power, but not being initialised… hmm, the plot thickens.

1 Like

Hi @Jon,

Did you have any luck narrowing down the fault any further? You seemed to be close to working it out at last update!

Or do you think it might need a board transplant? :open_mouth:

1 Like

Good news everyone!

Some updates to this. I did eventually go with a board transplant. There was no power to the USB and AGP slots, so I do suspect it has to do with the circuitry that handles pre-boot. I will have to inspect the defective mainboard later on, but in the meantime I got the machine booted up.


Next would be to work out what’s wrong with the RAM and why the speaker sounds so distorted.

3 Likes

Wow Jon, good progress.

I try to remember that sometimes it is just not possible to save all the computers. For this one though, with a brand new logic board:

  1. Do you have extra RAM DIMMs for testing?
  2. Those speakers probably have a rubber surround that has degraded - I’ll bet it is still loud though when it chimes!

Cheers,
Shane

Hi Shane,

I do have extra MAC133 RAM lying around and by some stroke of luck I managed to work out which one is the faulty one.

The speaker’s rubber surround seems ok. Someone mentioned that they have one for a mirror-drive-door G4 just lying around so I may try that too.

In other news, I found out that this unit came supplied with a not-so-common internal ZIP 250 drive. Will have to search for some media and test that out.

Regards,
Jon

2 Likes

That’s great news, did you have any way to check the RAM extensively? Perhaps Techtool Pro on a ZIP disk would be appropriate! :smiley: